MakuaMon is supported on Windows 7, 8 and 10. It requires administrative privileges to install and it requires Microsoft .Net 3.5 to be installed on your computer. .Net 3.5 comes pre-installed on most versions of Windows. But, don’t worry, the MakuaMon setup program will automatically download and install .Net 3.5 if it is not already installed.